Older Macs Pro and iMac 27-inch Late 2012 running macOS Mojave

Mac ProApple recently released macOS Mojave, an operating system for Apple’s computers – Macs. As minimum, you will need a Mac supporting Metal technology. Basically, you will need a Mac from 2012 or newer – except Mac Pro, you will need Mac Pro from 2013, a trash-can designed workstation. But if you upgrade stock GPU in modular Mac Pro models from 2010 or 2012 to Metal-capable GPU, your expensive workstation can run macOS Mojave. You just need right GPU.

Apple released list of supported GPUs for Macs Pro. Here is list:

  • MSI Gaming Radeon RX 560 – 4GB GDDR5, 128-bit
  • SAPPHIRE Radeon Pulse RX 580 – 8GB GDDR5
  • SAPPHIRE Radeon HD 7960 Mac Edition
  • NVIDIA Quadro K5000 for Mac
  • NVIDIA GeForce GTX 680 Mac Edition

Also, Apple released list of another GPUs, which should work with macOS Mojave:

  • AMD Radeon RX 560
  • AMD Radeon RX 570
  • AMD Radeon RX 580
  • AMD Radeon Pro WX 7100
  • AMD Radeon RX Vega 56
  • AMD Radeon RX Vega 64
  • AMD Radeon Pro WX 9100
  • AMD Radeon Frontier Edition

Another issue is with 27-inch iMac Late 2012 with 3 TB HDD. If you want to run macOS Mojave on this iMac, you will need to remove Boot Camp partition. If you need Windows on your iMac, you have to use 3rd party solutions like Paralles or VMWare. You have to backup all your datas from Boot Camp partition, because after installation of macOS Mojave, your Windows partition will be no longer supported.

Liked it? Take a second to support Lukáš Raynor Majer on Patreon!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.